無料ブログはココログ

最近のトラックバック

フォト

« 上野のスタシェーンで | トップページ | MacでPDFを見るときはskim »

2010/10/07

vmplayer 3.1.2 on Ubuntu 10.10でエラーが出た

Ubuntuを10.10に上げて、しばらくの間Vmplayerを使っていなかったら動かなくなっていた。
ということで、Vmplayerを3.1.2にバージョンアップしたら、今度はコンパイルでこけてしまう。

ナンジャラホイと、調べてみると、
/tmp/vmware-root/modules/vsock-only/linux/af_vsock.cのところでエラーが出ていた。

ということで、ググって
http://www.linuxinsight.com/persuading-vmware-workstation-7.1-to-cooperate-with-linux-kernel-2.6.35.html
で解決方法を見つけました。

このURLから "vsock.patch"をダウンロードして

cd /usr/lib/vmware/modules/source
cp -a vsock.tar vsock-orig.tar
tar xf vsock.tar
cd vsock-only/linux
patch -p0 < /path/to/vsock.patch
cd ../..
tar cf vsock.tar vsock-only
rm -rf vsock-only
vmware-modconfig --console --install-all
とすれば良いとのことで、そっくりそのままやってみると、無事makeできました。

うーん、でも昔のvmxが動かないなあ? なんでだろ。

追記(10.11.2)
なぜか、Ubuntu 10.10でvmplayerを……と考える強者(粗忽者?)が多いようなので。
旦那こんなところに情報がありますゼ

« 上野のスタシェーンで | トップページ | MacでPDFを見るときはskim »

「パソコン・インターネット」カテゴリの記事

トラックバック

この記事のトラックバックURL:
http://app.cocolog-nifty.com/t/trackback/198480/49674517

この記事へのトラックバック一覧です: vmplayer 3.1.2 on Ubuntu 10.10でエラーが出た:

« 上野のスタシェーンで | トップページ | MacでPDFを見るときはskim »